Republished: Battery Not Charging on SV650

Originally published on Benscomputer.no-ip.org Feb 2009.

 

This page is here as a reference for others experiencing the issues I have been having on my 2002 SV650-S lately.

SYMPTOM: Battery not charging, so bike refuses to start every so often. Misfire in Idle range but not always on the same cylinder.

 



The first thing to check is whether your battery is actually charging, if it is then you could spend quite a while diagnosing the wrong problem. Take the front seat off the bike to gain access ot the Battery bay, put a multimeter between the +ve and the -ve terminals of the battery and note the voltage.

Next start the engine and put the multimeter across again, even at low revs you should see somewhere between 13 and 14 volts, if not then rev the engine whilst keeping the multimeter on the terminals. If the voltage appears to drop then you may have the same issue as me.

Check the Regulator/Rectifier using the measurements in the service manual, if that seems fine, run a generator no load check.

Disconnect the R/R and start the engine, place your multimeter probes between 2 of the ground wires (there are three yellow or black wires) on AC voltage setting. Run your revs up to 5000, if you are seeing a voltage > 60VAC then the generator is fine.

Chances are you either have a dodgy earth, or like me resistance on the hot wire.

Carefull put a wiere between the negative wire of the R/R and the -ve Battery terminal. Then check to see whether the bike is charging or not, if not then disconnect that and place the wire between the +ve wire of the R/R (Red or Red/Black wire) and the +ve terminal of the battery. Check again if the battery is charging. Mine was, so I made the wiring more permanent and added an inline fuse for safety. Whilst this meant the battery charged the misfire has continued, so I have to keep the revs above about 2500 RPM.

It appears to be a corroded contact on the starter relay, just infront of the rear wheel. This is scheduled for replacement at the end of the week, and I am confident that it will resolve the issue.

 

Update: Replacement relay resolved issues

 
 Share