Beware USB Quick Charge Ports

In order to power a couple of thermistor controlled cooling fans, I use a pair of USB to 3 pin Molex adapters.

I noticed the other day that one of the fans wasn't working, so I detached it from it's mounting plate and brought it and the adaptor out to check.

Access is a bit... tricky... so I couldn't really test the adaptor against the other fan (and didn't want to risk breaking it if something odd had gone wrong). The fans I use are about £5 each, and it's always worth having spares, so I ordered some replacements, which arrived today.

I plugged one of the new fans into the adaptor and tried to power it on. Nothing. So, I dealt with the access issues in order to plug the new fan into the other adaptor to check the fan worked - it did.

The last remaining check then, was to verify that the issue didn't lie with the USB port the adaptor was plugged into.

 

The USB power supply I use to run the fans is essentially a four port charging block, with 3 of the ports in use. So, I absent mindedly unplugged the adaptor and moved it into the spare port. At which point two things happened

  • The magic smoke escaped
  • I burnt my thumb

The fourth port on that block is a Quick Charge 2.0 port. In other words, assuming the software thinks it's OK to do so, it'll happily chuck 3 amps over the connection.

Of course, the power supply isn't technically supposed to push 3A's just like that, but at this point we can recognise that this cable was already, in some way, faulty.

The reaction was instant, there was a little pop, flash and the magic smoke drifted happily away to start it's new life. Unfortunately I was still holding the connector at the time, so the tip of my thumb got a nice toasting.

That's around about the time I remembered that the 4th port was Quick Charge. Those of you who followed the link to the adaptor may have noticed the words "Maximum of 400 mA.". Whoops

So, I did what any normal person would do, and broke the connector apart to see what damage had been done

We can see the epicentre of it almost immediately.

Unrelated, but interestingly, during manufacture there's some exposed wire on the back (look closely at the red and black that curl back down)

The USB port is was previously plugged into is working, and is capable of delivering 2As if there's sufficient draw. That would suggest that the adaptor somehow convinced the Quick Charge firmware that it was a device capable of receiving a >2A draw.

 

That the adaptor didn't fail safe is worrying (especially as there's still another in use), but that aside this is largely a story of human error. When I put that power block in there, I knew that the quick charge port should not be used, on the basis that whilst it would probably be safe, it's not worth the risk.

What I didn't do, though, is prevent its use (by perhaps taping the port off, or putting a USB blanker in), which meant that in a moment of distraction I was able to unthinkingly plug something into it. Although my thumb stings a bit (and I can still smell the elusive smoke) it could have been far, far worse - what if the fan had worked initially? I'd have re-installed it and wandered off, only for the thing to start smoking and burning.

So, be aware of what USB Quick Charge ports (and other high current supplies, for that matter) are capable of, and make sure you put protections in place to avoid stupid accidents.

 
 Share